Error: DynamoDB aliasing is not supported

Answered by Rafal Wilinski
What's Causing This Error
The error "Dynamodb aliasing is not supported" occurs when you try to use aliasing in a DynamoDB query or update. Aliasing is a feature that allows you to rename attributes in the query results, but it is not supported in DynamoDB.
Solution: Here's How To Resolve It
To solve this error, you can execute the following:
- Instead of using aliasing, you can use the attribute names as they are in the table.
- However, if your attributes are part of the reserved attributes in DynamoDB, you will need to alias it using "#" in the expression and defining its real attribute name in the
ExpressionAttributeNames
Other Common DynamoDB Errors (with Solutions)
- dynamodb list_append returns true but does not work
- dynamodb exclusivestartkey not working
- DynamoDB Not Supported Requires @DynamoDBTyped Or @DynamoDBTypeConverted
- dynamodb request is missing authentication token
- dynamodb unable to execute http request
- DynamoDB attribute not empty
- aws.dynamodb.documentclient is not a constructor
- DynamoDB TTL Not Working
- DynamoDB No Regionendpoint Or Serviceurl Configured
- dynamodb could not load credentials from any providers
- DynamoDB stream not working
- dynamodb cannot convert undefined to object
- DynamoDB Query Limit Not Working
- DynamoDB Network Error: self signed certificate in chain
- error updating dynamodb table time to live
Dynobase is a Professional GUI Client for DynamoDB
Start your 7-day free trial today
Product Features
DynamoDB Tools
DynamoDB Info
© 2026 Dynobase