Error: failed to list tables not authorized dynamodb

Answered by Rafal Wilinski
What's Causing This Error
This error occurs when the service invoking the DynamoDB ListTables operation does not have the required identity-based policy.
In simple terms, the service invoking the DynamoDB API does not have the required permissions to execute the ListTables operation.
Solution: Here's How To Resolve It
To solve the error, visit the IAM console and locate the IAM role assigned to the service. Then, attach the inline policy shown below to the IAM Role.
{
"Version": "2012-10-17",
"Statement": [
{
"Sid": "allowListTablesPolicy",
"Effect": "Allow",
"Action": "dynamodb:ListTables",
"Resource": "*"
}
]
}
Afterwards, save the changes to the role. The ListTables operation will work the next time you execute the operation via the service. However, ensure that you have added the policy to the correct role.
Other Common DynamoDB Errors (with Solutions)
- dynamodb local could not load credentials from any providers
- error retrieving dynamodb table item serializationexception
- a bytes-like object is required not binary dynamodb
- DynamoDB string set cannot be empty
- DynamoDB no attribute schema defined
- dynamodb the parameter cannot be converted to a numeric value
- DynamoDB cannot do operations on a non-existent table
- DynamoDB Contains not working
- ExpressionAttributeValues contains invalid value: One or more parameter values were invalid: An AttributeValue may not contain an empty string
- DynamoDB stream lambda error
- DynamoDB BatchWriteItem error
- error updating dynamodb table time to live
- dynamodb does not accept empty set
- DynamoDB BatchSave not working
- DynamoDB missing items
Dynobase is a Professional GUI Client for DynamoDB
Start your 7-day free trial today
Product Features
DynamoDB Tools
DynamoDB Info
© 2026 Dynobase