Error: Unable to start DynamoDB Local process

Answered by Rafal Wilinski
Solution
Error occuring when trying to start a Local offline DynamoDB instance, often appearning when using Serverless Framework.
First, make sure you have Java JDK & JRE (Java Runtime Engine) version 6.x or newer is installed on your machine since it is required by the Local DynamoDB.
Usually error gets fixed by executing the following set of commands:
yarn remove serverless-dynamodb-local yarn add serverless-dynamodb-local@0.2.35 sls dynamodb install
If you want to use versions after 0.2.26 make sure to execute the
following command instead of sls dynamodb install:
sls dynamodb install --localPath ./bin
After you have installed the Local DynamoDB, you can start it by executing the following command:
sls offline start
If DynamoDB Offline is still not running, it might be failing to do so because
port 8000 is already in use. You can run DynamoDB Offline on a
different port by specifying -p option to the
sls offline start command like so:
sls dynamodb start -p 8000
Other Common DynamoDB Errors (with Solutions)
- CORS Error DynamoDB
- dynamodb unknown error
- dynamodb consistent reads are not supported on global secondary indexes
- DynamoDB No Regionendpoint Or Serviceurl Configured
- dynamodb attribute does not exist
- dynamodb global secondary index not working
- dynamodb the parameter cannot be converted to a numeric value
- dynamodb global secondary index does not project
- dynamodb does not accept empty set
- DynamoDB local error unable to access JAR file dynamodblocal.jar
- aws.dynamodb.documentclient is not a constructor
- DynamoDB throttling error
- name key is not defined dynamodb
- DynamoDB failedbatch retry
- DynamoDB Duplicate Key Error